Função FWGetMnuAccess retornando vazio

Boa tarde.

Estou usando a função FWGetMnuAccess para elaborar um relatório para a auditoria, mas de um tempo para cá a função está retornando nulo para os usuários que não sejam o administrador. Tentei aplicar atualizações de LIB e Binários mas o efeito é o mesmo. Algum procedimento que eu possa tentar?

Grato,

Leandro Michelsen

compartilhar
  • Leandro, nada mudou nessa função, é gerado algum error.log no console? Ela é uma função que abre uma nova thread para colher as informações, então o error.log não seria explícito, talvez ao no console.

    Daniel Mendes   15 de Oct de 2020
  • Eu abri um chamado e foi testado. Em resposta foi evidenciado que a função está funcionando conforme o documentado mas foi efetuado o teste numa base com o dicionário no banco. Mandei agora o arquivo sigapss.spf para que seja testado pois suspeito que houve alguma alteração em função da nova sistemática com o dicionário no banco que possa ter afetado o funcionamento do legado. Vou esperar a resposta mas já vou correr com a migração do dicionário. Qualquer novidade informo aqui.

    Leandro Michelsen   16 de Oct de 2020
  • Finalmente consegui migrar o dicionário para o banco mas, para a minha decepção, a função ainda retorna nulo para todos os usuários.

    Leandro Michelsen   26 de Nov de 2020
  • Analisei o console.log e as mensagens que aparecem para cada vez que rodo a função são:

    2020-11-26T14:46:55.210000-03:00 2444|

    2020-11-26T14:46:55.210000-03:00 2444|aPWC -> U ( 1) [ ]

    2020-11-26T14:46:58.247000-03:00 5124| [INFO ][SERVER] [Thread 5124] JOB Thread finished [-FWAUXGETMNUACCESS]

    2020-11-26T14:46:58.256000-03:00 2444|

    2020-11-26T14:46:58.256000-03:00 2444|aPWC -> U ( 1) [ ]

    2020-11-26T14:47:00.844000-03:00 5636| [INFO ][SERVER] [Thread 5636] JOB Thread finished [-FWAUXGETMNUACCESS]

    Leandro Michelsen   26 de Nov de 2020
  • Fiz alguns testes e descobri quando ocorre o problema: Quando na política de Segurança, a Modalidade de Single Sign-on está igual a 3-Active Directory, o sistema traz conteúdo nulo no retorno da função FWGetMnuAccess. Quando eu mudo para 1-Sistema Operacional, o sistema retorna a matriz com os acessos do usuário.

    Leandro Michelsen   26 de Nov de 2020
  1. Você vai ver essas setas em qualquer página de pergunta. Com elas, você pode dizer se uma pergunta ou uma resposta foram relevantes ou não.
  2. Edite sua pergunta ou resposta caso queira alterar ou adicionar detalhes.
  3. Caso haja alguma dúvida sobre a pergunta, adicione um comentário. O espaço de respostas deve ser utilizado apenas para responder a pergunta.
  4. Se o autor da pergunta marcar uma resposta como solucionada, esta marca aparecerá.
  5. Clique aqui para mais detalhes sobre o funcionamento do TOTVS DevForum!

1 resposta

Não é a resposta que estava procurando? Procure outras perguntas com as tags advpl ou faça a sua própria pergunta.