Envio de relatório TREPORT por E-mail

Olá guys, estou tentando utilizar a opção de enviar um treport via e-mail, e até encontrei uma documentação da TOTVS repassando os parametros necessários para que isso acontecesse.

https://centraldeatendimento.totvs.com/hc/pt-br/articles/360040696874-MP-ADVPL-ENVIO-DE-RELAT%C3%93RIO-TREPORT-VIA-E-MAIL-EM-FORMATO-PLANILHA

Entretanto, tentei usar o mesmo exemplo que foi repassado pela TOTVS, e:

1 - Quando eu simulo via job não acontece absolutamente nada 2 - Quando eu removo as funções RPCSetEnv / RPCClearEnv para que seja executado via Gui , o sistema da um erro na linha 36:

variable does not exist IMP_EXCEL on U_T248START(T248START.PRW) 07/01/2021 21:52:57 line : 36

Sendo que a seguinte varíavel é uma das premissas para funcionar o processo.

Alguém já tentou usar essa documentação para o mesmo objetivo ou sabe o porque ocorreu o erro?

compartilhar
  • Michel, você tem a printer.exe na pasta do seu appserver?

    Daniel Mendes   08 de Jan de 2021
  • Tenho sim Daniel, inclusive atualizei ele com a ultima versão do portal , 12/2020. Atualizei no appserver e no smartclient

    Michel Fernandes   08 de Jan de 2021
  1. Você vai ver essas setas em qualquer página de pergunta. Com elas, você pode dizer se uma pergunta ou uma resposta foram relevantes ou não.
  2. Edite sua pergunta ou resposta caso queira alterar ou adicionar detalhes.
  3. Caso haja alguma dúvida sobre a pergunta, adicione um comentário. O espaço de respostas deve ser utilizado apenas para responder a pergunta.
  4. Se o autor da pergunta marcar uma resposta como solucionada, esta marca aparecerá.
  5. Clique aqui para mais detalhes sobre o funcionamento do TOTVS DevForum!

0 resposta

Não é a resposta que estava procurando? Procure outras perguntas com as tags treport ou faça a sua própria pergunta.