Primeiro acesso ao servidor Rest lento

Bom dia pessoal,

Estou com o seguinte problema, não sei se já passaram por isso, criei um serviço em Rest, uma API de cadastro de autônomo e uma outra de pagamentos, quando eu consumo o serviço pelo primeira vez, através do Postman, meu servidor demora quase 30 segundo para responder de depois disso todas requisções demoram aproximadamente 6 segundos.

Pensei se seria algum problema da API, mais isso acontece em todas API's que tenho testado, basta eu reiniciar o serviço e ocorrer essa demora, já entrei em contato com a Totvs me pediram para fazer vários procedimentos e não solucionou o problema.

Agradeço qualquer ajuda.

compartilhar
  • Roberto, se você subir o REST e esperar 1 minuto para efetuar a requisição, você tem essa demora mesmo assim? Qual REST você está utilizando?

    Daniel Mendes   30 de Aug de 2021
  • Estranho, trabalho com o REST da TOTVS, porém essa mesma situação não ocorre.

    Clodoaldo Ribeiro   3 months ago
  • Alguma novidade sobre isso?

    VINICIUS GATI   3 months ago
  1. Você vai ver essas setas em qualquer página de pergunta. Com elas, você pode dizer se uma pergunta ou uma resposta foram relevantes ou não.
  2. Edite sua pergunta ou resposta caso queira alterar ou adicionar detalhes.
  3. Caso haja alguma dúvida sobre a pergunta, adicione um comentário. O espaço de respostas deve ser utilizado apenas para responder a pergunta.
  4. Se o autor da pergunta marcar uma resposta como solucionada, esta marca aparecerá.
  5. Clique aqui para mais detalhes sobre o funcionamento do TOTVS DevForum!

1 resposta

Não é a resposta que estava procurando? Procure outras perguntas com as tags rest restapi api ou faça a sua própria pergunta.