Erro na utilização da função FWFormModel()

Boa tarde!

Estou tendo um problema em uma tela MVC que estou criando. Quando fui definir dentro do modelDef o objeto oModel, utilizei a função FWFormModel, para poder criar uma pós validação quando o usuário clicar em confirmar.

Definir o oModel dentro do ModelDef da seguinte maneira:

Local oModel := FWFormModel():New('XHESTI_01R',{||.T.}, { |oModel| COMP011POS(oModel) },{|oModel| commit(oModel)},{|oModel| cancel()})

Quando fiz isso, a inclusão e validação está funcionando perfeitamente. Entretanto, a alteração e visualização está dando erro, e eu não tenho idéia do porque.

erro no parâmetroFWFormFieldsModel: Bloco de código (bLoad) para carga dos dados do Id 'MD_MASTERZA3' não é válido on FWFORMFIELDSMODEL:ACTIVATE(FWFORMFIELDSMODEL.PRX) 12/07/2019 17:33:43 line 186.

compartilhar
  1. Você vai ver essas setas em qualquer página de pergunta. Com elas, você pode dizer se uma pergunta ou uma resposta foram relevantes ou não.
  2. Edite sua pergunta ou resposta caso queira alterar ou adicionar detalhes.
  3. Caso haja alguma dúvida sobre a pergunta, adicione um comentário. O espaço de respostas deve ser utilizado apenas para responder a pergunta.
  4. Se o autor da pergunta marcar uma resposta como solucionada, esta marca aparecerá.
  5. Clique aqui para mais detalhes sobre o funcionamento do TOTVS DevForum!

2 respostas

Não é a resposta que estava procurando? Procure outras perguntas com as tags mvc ou faça a sua própria pergunta.