Abertura SX1 Com OpenSxs ou FWSX1Util

Boa tarde Pessoal,

Estou com problemas para fazer a leitura da SX1. Preciso chamar a função Pergunte para coletar os parâmetros do usuário e preciso pegar alguns campos na SX1 para verificar como tratarei os parâmetros coletados. Tentei efetuar a leitura usando primeiramente a classe FWSX1Util, porém esta sempre me retorna a posição vazia para o array que recebe o resultado da consulta. Posteriormente tentei usando a função OpenSXs, mas quando verifico a abertura da área com o comando Select sempre retorna FALSO. Abaixo, seguem os dois trechos de código que usei pra cada método: FWSX1Util:

Local oObj := FWSX1Util():New()
Local aPergunte

oObj:AddGroup(cPerg) // cPerg := "DATA  "(ja conferi o conteúdo da variavel)
oObj:SearchGroup()
aPergunte := oObj:GetGroup(cPerg)

OpenSXs:

OpenSXs(NIL, NIL, NIL, NIL, cFilAnt, cAlias, "SX1", NIL, .F.)
lOpen := Select(cAlias) > 0

If (!lOpen)

    lOpenDic := .F.
    Return
EndIf

Algum de vocês teve problema na abertura da SX1? A SX3 eu consigo abrir normalmente com o OpenSXs Alguém teria um outro método de fazer acesso ao dicionário de dados??

compartilhar
  • Ivan, qual a necessidade de verificar os campos da SX1? No que a função Pergunte não lhe atende?

    Daniel Mendes   1 month ago
  1. Você vai ver essas setas em qualquer página de pergunta. Com elas, você pode dizer se uma pergunta ou uma resposta foram relevantes ou não.
  2. Edite sua pergunta ou resposta caso queira alterar ou adicionar detalhes.
  3. Caso haja alguma dúvida sobre a pergunta, adicione um comentário. O espaço de respostas deve ser utilizado apenas para responder a pergunta.
  4. Se o autor da pergunta marcar uma resposta como solucionada, esta marca aparecerá.
  5. Clique aqui para mais detalhes sobre o funcionamento do DevForum TOTVS!

1 resposta

Não é a resposta que estava procurando? Procure outras perguntas com as tags opensxs fwsx1util sx1 ou faça a sua própria pergunta.